Recovering from failed configuration import or restore

Problem

After restoring a configuration, I sent a new cad to my users device and performed a new load but I cannot see anything on my device.  The load complete, but nothing is displayed.

Compatibility warning

Configuration files are not compatible between server versions.  For example, you cannot restore a Version 9 server configuration file to a Version 10 server, it should be restored to a Version 9 server, which should then be upgraded to Version 10 using the Swift MEAP™ Installer

Possible causes

Typically, this is caused by either missing Menu Labels, Field Labels, record description fields or keywords.  Essentially, something is missing from the configuration file, so the client doesn't know how to display data.

In a list of records, the records description fields (Menu Settings) control which fields are displayed, the client cannot display anything if these fields are not present, have no labels etc.

It can be caused by a corrupt configuration or importing an incorrect configuration version.

Solution

To recover, check the config version that you are recovering from, was it the same sever version as your current server.  In the latest servers, instead of importing a script, use the rollback configuration feature.  Check that the full restore procedure is followed and reattempt the restore

Rollback configuration steps
To roll back a configuration to an earlier state:
  1. In the Swift MEAP™ Admin Console, go to Utility->Configuration Tools
  2. Enter your MySQL login details
  3. The option you have available will depend on your server version:
    1. In the latest servers, you have a 'Rollback configuration' option, tapping on 'Configuration' will list previous configs, select one and its script is automatically read
    2. In previous versions, configurations were not saved so you will need to use the 'Upload Script" function to restore a file you have saved locally
  4. Once the file / configuration has been read, the scripts being executed are displayed.  Select Execute and enter your Admin password (Swift MEAP™ Server Admin password)
  5. Any errors should be reported, please report any to your support desk.  After the script has executed, select Back to go back to Configuration Tools screen. 
  6. When a configration has been read, it is stored in a backup table, you now need to copy this to your active configuration.  To do so, select Restore and enter your admin password again
  7. You can now check the configuration, save a new cad and reload your device

This should restore the configuration to an earlier working state, you will still need to check that labels are present, keywords are present etc.  If any labels are missing, use Cad Management to reconfigure your language and reread labels from your data source.  Please also reset and read keywords, if keywords are missing.

Finally, check the menu setting for any object that you are having trouble with, are Record Description Fields configured and are those fields present in the Map Settings for that module?